cordova run iOSでiso-deployが古いと言われる

このエントリーをはてなブックマークに追加

ios-deployが古いって言われた

cordova run iOS

久しぶりにcordovaをインストールしてとりあえず実行したら以下のようなエラーが出た。

Cordova needs ios-deploy version 1.2.0 or greater, you have version 1.1.0.
ERROR running one or more of the platforms: Error: /path/to/project/platforms/ios/cordova/run: Command failed with exit code 1
You may not have the required environment or OS to run this project

ios-deployが古いってさ。↓みたいな文章が書いてあったらもうちょっとうれしかった。

Updating the npm package ios-deploy may solve this problem.

そもそもios-deployをnpmで管理していたこと自体忘れていたので。。。ということで以下を実行してバージョンアップしておけば解決します。

sudo npm update -g ios-deploy
Written on January 31, 2015
このエントリーをはてなブックマークに追加